Slow

@mayrose (323)
Philippines
September 18, 2008 10:08am CST
my computer has windows vista ready, but when i used it to my internet explorer it slows down, and my network is slow. Now i uses mozilla and sometimes its fine but it slows down too, now i dont know if it is my network provider or just my computer.
4 responses
• India
18 Sep 08
vista is very much heavy on the system. vista has this problem of slowing down the system, internet explorer also gets hanged some times. had this problem for long time. then, i shifted back to windows xp, now it fine. xp is much lighter than vista on the system.
@mayrose (323)
• Philippines
19 Sep 08
thank you i will take your suggestion..
@modstar (9608)
• Philippines
18 Sep 08
Maybe you're having hardware problems. Windows Vista is known to be a resource hog and you need major hardware upgrades if you want Windows Vista to work smoothly.
@mayrose (323)
• Philippines
19 Sep 08
thank you i think i have to take your advice
• India
19 Sep 08
Vista need the high configuration system to run but not for xp it can run fast in less configuration systems also and may be your computer got virus it also one for the problem to become like that so you try to install a good antivirus software like kaspersky or norton it will remove all the virus files in you computer then try ok.
@Sillychick (3279)
• United States
18 Sep 08
I used Vista for a while, and I found it was slow. I also heard the same thing from several other people who used it. I hated it, so I switched back to XP. It may be your network, but I wouldn't doubt if it was because of Vista.