Uh....What Just Happened Here?

United States
May 6, 2009 7:38pm CST
Just a few minutes ago I went to PayPal.com and tried logging into my PayPal account. Except when I tried logging in, I was take back to the login page and now everything is written in Chinese (Japanese? I don't know). Is this happening with anyone else or is it just me? Or has it happened to anyone else? This has never happened before to me.
1 person likes this
3 responses
@srikandi19 (3393)
• Kuta, Indonesia
7 May 09
I'm still fine when open Paypal. perhaps you change the language with Chinese/Japanese. Sometimes I change Papypal language to my mother language. So .. Check the Language on paypal site.
1 person likes this
• United States
7 May 09
I went into my paypal account and all is fine.. If it continues call them and find out what is going on.. is all I can suggest. First, log out, clean cookies and temp files, reboot, then try again and see if it is still the same, if it is, CALL right away..
• United States
7 May 09
That seemed to work. The Chinese lettering disappeared and returned to English. It let me log in but then it took me to a screen that had my credit card info and asked me to verify my identity with the full card number. According to it my account was randomly selected for security measures. Do you know if this is legit? I've never had this happen to me either. I want to make sure before entering anything.
1 person likes this
• United States
7 May 09
One more thing since that happened regardless how it happened, CHANGE YOUR PASSWORD IMMEDIATELY .. sorry forgot to add that to the previous message
• United States
7 May 09
Sorry I didn't answer right away, one of my sisters called, still dealing with things from my Mom passing... No I have not had that happen to me at all. I have been in Paypal since the first year it started. What I would do if I were you, is in the morning give them a call see if what is going on is right or not. This way you will know for sure.. let me know if it turns out ok or not..
@LadyMarissa (12160)
• United States
7 May 09
Mine opened up just fine!!! Maybe you need to try again. Any chance you changed the language??? I've never done that, but I could see it happening!!!
• United States
7 May 09
The good news is that the language thing worked out. But now it's requesting I put in my credit card # because my account was randomly selected for some security measure or whatever. I'm trying to make sure my account hasn't been hacked or anything before I continue with that.