taking surveys

United States
March 7, 2010 2:12pm CST
I am registered with several survey sites and most of them I can use with no problems. However, there are a few sites that everytime I click on "take survey", then it will not let me on and then says, "technical difficulties." I have e-mailed them and they said to check my browser and then clear my temporary internet files. My browser is explorer 8, which should be good enough and I tried to delete temporary internet files but nothing seems to work. Does anyone have any ideas what might be the problem? When replying, keep in mind that I am computer illiterate so you might have to spell it out for me. Thank you.
1 person likes this
4 responses
@sushie93 (1359)
• France
7 Mar 10
Have you ever tried with Mozilla Firefox browser? Sometimes somes sites doesn't work at all with Internet Explorer even if browser is recent...
1 person likes this
• United States
8 Mar 10
Thanks. Firefox worked.
@techgurl (451)
• Greece
7 Mar 10
Get rid of Internet explorer and try a new browser. All of them are free and a lot better than ie. Try Mozilla Firefox or Opera. I don't think you will be having problems with any of them, as long as it is no internet explorer.
• United States
8 Mar 10
Thank you. Firefox worked.
• United States
7 Mar 10
I went over to firefox a while back, now I almost never use IE for anything, I especially hate IE8, none of my surveys credited with it, so I went back to IE7 and still had trouble, Firefox works like a charm for me, there are still a few that wont credit but it works way better!
• United States
8 Mar 10
You are right. Firefox works.
@iridium (436)
7 Mar 10
check your settings for flash and java. they often want up to date versions of flash, java and quicktime.