Does anyone have trouble logging on to MyLot?

@kgwat70 (13395)
United States
November 19, 2006 7:29am CST
I keep having to type my username and password in twice in order to use this site. Is anyone else having the same problem? Are they still working on the site?
1 person likes this
16 responses
@freesoul (3023)
• Egypt
28 Dec 06
I had similar problem 3 days ago, each time I enter ID/pass i get forwarded back to homepage without any error message or anything, I'm 100% sure ID/password is correct, I tried again and it happened 3 times than I was able to login 4th time but that was only one time problem I guess because it didn't happened again.
1 person likes this
@kgwat70 (13395)
• United States
29 Dec 06
Someone told me that this could be a case of phishing so you should be careful and should let myLot know if you have this problem again.
@no1biz (262)
• Sweden
22 Nov 06
I had that kind of problems with other websites with login as I used the Firefox browser. Are you using Firefox or Internet Explorer? I think you have to use the last one.
@kgwat70 (13395)
• United States
29 Dec 06
I use Firefox most of the time but I have had problems before with both Firefox and Internet Explorer so I think it had to be the website itself having problems.
@birthlady (5613)
• United States
20 Nov 06
Its called "PHISHING" and it happened to me. Do not log in twice! Phishing is a fake page, when you log in again, you give the person (criminal, really) all of your login username and password info. I had trouble with this fake log in pages for 3 days. Close your browser when it happens. Open a new browser. Choose any other mylot page to log into. Check to make sure it says "my profile--earnings$--logout" on the right hand top of the page and it should show your username also. If not--YOU'VE BEEN PHISHED! I found two kinds of spyware on my computer after all this phish stuff.
@kgwat70 (13395)
• United States
22 Nov 06
Thank you for that information. I haven't had any problems since that day so hopefully my computer is okay. Maybe I should change my login information?
• Singapore
19 Nov 06
Thank you for this discussion! I've been having that problem everytime i tried to login...and it's not only today. since i joined until now, i think there's only 1 day that i can login with 1 attempt!
1 person likes this
@kgwat70 (13395)
• United States
22 Nov 06
You are very welcome. Someone mentioned that it is called Phishing and that someone is trying to steal our information. We should check our computers for spyware.
@nancygibson (3737)
• France
19 Nov 06
I know they had the site down for maintenance yesterday, but its running ok for me. Have you checked that you are accepting cookies ok?
@kgwat70 (13395)
• United States
19 Nov 06
Yes, I have checked. Thanks for the info as it seems to be okay now. Had problems the last couple days though.
• India
21 Dec 06
no i have not trouble logging on to mylot .
1 person likes this
@jay80son (2048)
• Italy
20 Nov 06
yes but it's caused by my firewall spyware advisor
1 person likes this
@disturbedgd (1821)
• South Africa
20 Nov 06
i put mylot in my faviroutes while im logged in so each time it logs in automatically for me ^.^
1 person likes this
@krizz420 (4387)
• Canada
20 Nov 06
Some days I do but not to often
1 person likes this
@happygal68 (3277)
• United States
20 Nov 06
I am sure they are always working on the site. Maybe it is just a glitch that is causing this to happen. I have never had a problem yet logging onto MyLot ( I hope I didn't just jinx myself lol)
@kutchi (12330)
• Pakistan
19 Nov 06
Yes, Same problem here for last 2 days
1 person likes this
@massaj03 (4372)
• United States
19 Nov 06
Nope actually I have never had trouble logging in, unless it said they were temporary down for something.
• United States
19 Nov 06
I'm constantly having similar sorts of login difficulties with this site, as well as experiencing a number of other techicals problems here. Obviously, mylot has ample room for making improvements that would rectify such issues. However, they don't appear to be proactive, at least with respect to addressing my concerns when I've contacted them via email.
@fl0urish (5385)
• India
19 Nov 06
no i dont have
1 person likes this
@cyfernet (2384)
• United States
19 Nov 06
yes i'am having the same problem...the address comes as 'www' first then changes to 'www2'
1 person likes this
@Sorathian (4329)
• Pakistan
19 Nov 06
yes some times
1 person likes this