Is it just me or is there something wrong with my lot?

@teenal (1420)
Dublin, Ireland
December 6, 2006 4:25pm CST
Prob just my PC but every time I submit post or topic and hit the submit button its taking ages and ages to go through. Everything else on my PC is flying along. Its only tonight and its driving me away. No more posts from me tonight. Just havent the patience. Night all.
3 responses
• United States
6 Dec 06
Yes, I have noticed it too. I just replied to some other message and it gave me the message Unable to send this message now, try agian later, several times until it finally wne through. Servers could be backed up or overloaded right now, especially if everyone is trying to post at the same time. Best solution would be to wait until later or just keep hitting the post response button until you get through. Other than that there's not much you can do.
@teenal (1420)
• Dublin, Ireland
6 Dec 06
Thanks for the reply. Glad its not just me. I have been hitting the submit more than once in fustration and then some of my posts show up twice. Wonder if I will get paid twice. Might keep it up if I do.lol.
@teenal (1420)
• Dublin, Ireland
6 Dec 06
Thanks for the reply. Glad its not just me. I have been hitting the submit more than once in fustration and then some of my posts show up twice. Wonder if I will get paid twice. Might keep it up if I do.lol.
@mfrancq (1808)
• United States
6 Dec 06
It has been doing that since at least 5am here and it's 4pm here now. I don't know what is going on but I just keep plucking away at it. Hopefully we will have better luck tomorrow. Best wishes!
@TerryZ (22083)
• United States
6 Dec 06
Its not you its happening to me too. Ive been on most of the afernoon and its been doing it. I am ready to get out of here.