Error 404 : Missing Page Alert!

The Evil Sloth! - This is one of the current images being used to let you know you've reached a page that has been moved or is no longer available.
@freak369 (4914)
United States
July 3, 2007 2:13am CST
Anyone else been getting these mysterious pages when you refresh a shop or are using the Shop Wizard? I get them about once a minute, I'd like to think that my computer is so ultra fast that the Neopet servers just can't handle it but I know that isn't the case! Anyone else having this problem? I am using the Opera browser .. maybe that is why it's being so stubborn!
4 responses
• United States
3 Jul 07
I get them randomly through out the site. I either just go back or refresh the page and it goes back to normal, but it is still annoying! lol. I hate getting that page.
@freak369 (4914)
• United States
3 Jul 07
Since today is half off day it is really really super annoying! Say you online at the site, hope you are getting some great deals today!
• United States
18 Sep 07
I haven't had that problem myself. Try using firefox or explorer, they don't seem to be having problems.
@Seaclans (215)
• United States
4 Jul 07
It's been happening to me the last couple of times I've been on. Utterly at random. I'm not getting it as frequently as you are, though. I use Firefox, so it's probably not your browser. It is probably a bug in the new version of Neopets that hasn't quite been worked out yet.
@brendalee (6083)
• United States
3 Jul 07
I'm using internet explorer and I am getting those pages too. I have been for the past few days. Yesterday wasn't so bad but I just came back from there after doing my dailies, and it was doing it again. I was thinking that maybe their servers were a bit overloaded.