I can't get in Sidetick today, can anyone?

United States
November 24, 2010 10:29am CST
I have problem to get in sidetick.com this morning. My first try was an error message showing the site server can not establish the connection. The second attempt was, there is an empty page. The third attempt was the same. What is wrong with sidetick now? Are they undergoing some sort of maintenance work? Please let me know once it is up again.
4 responses
• Hong Kong
24 Nov 10
I have not heard of this site, so I don't know the url of it. Yet, you can try using this tool. Enter the URL in the middle text box, and this tool will tells you if the site is down for everybody or if it is just you. http://9c69d425.ubervidz.com
• United States
24 Nov 10
Great tool to check whether site is up or not. Thanks!
• Canada
24 Nov 10
That was a great link! Thanks for sharing
@TeamCholent (2844)
• United States
24 Nov 10
The site works perfectly fine for me and have never had any issues trying to log in. It might be an issue with your Internet. Maybe try clearing your cache and try logging in again? I am just waiting for them to pay me, lets hope it comes soon.
• United States
24 Nov 10
Now, I check it again. It is up. It was an hour ago, this site wasn't running at all. I got the error message and a blank page. I just wondering what was going on though!
• United States
24 Nov 10
I see that you were able to get back into the site, that's great. As I was in it this morning about 9:30am all of sudden I received a blank page. I thought to myself that maybe it is just one of those moments where the site is so intrusive that I get a blank page often but then I noticed it wouldn't let me back in and did not until 11 am. From what I understand they make updates to some scripting that cause a small failure. Anyways happy you got in and that you are able to tick for the day. I too am a happy member up there and just wanted to say hi.
24 Nov 10
I am on Sidetick right now and have not really experienced much trouble with being able to get on the site, If I have it has only been brief and I can't think of anything recent regarding it being down or not working properly. I have posted on the daily blog and have accepted a few friend requests today without any trouble so I guess it was just a slight glitch.