So What Did I Miss?

United States
June 4, 2016 12:10pm CST
For the last 11 days I've just been popping in and out, but I know one day my bank was at zero. Didn't think much about it because I thought maybe it was pay time!! But it wasn't guess it was a glitch. Then I was having problems with my pictures showing up side ways...which has NEVER happened before. Today when I logged in I saw that some one mentioned that the site was down or something yesterday So, now that the grand children are gone and I have time I logged on and wondered what I had missed??? ~Peace~ photo courtesy of pixabay
5 people like this
5 responses
@JolietJake (51107)
• United States
4 Jun 16
Good question, I didn't have any site problems yesterday.
1 person likes this
@yukimori (9072)
• United States
4 Jun 16
I didn't, either, but I wasn't on for more than a couple of minutes here and there.
1 person likes this
@TheHorse (72505)
• Walnut Creek, California
28 Oct 16
I've never had the sideways photo issue. Did it correct itself?
1 person likes this
@MGjhaud (20672)
• Philippines
5 Jun 16
mine's working okay yesterday, i was the one who was not working very much okay though.
1 person likes this
@celticeagle (119872)
• Boise, Idaho
4 Jun 16
We did have a glitch for awhile a day or so ago for a while. It is all working fine now.
1 person likes this
• Jacksonville, Florida
4 Jun 16
I didn't have issues yesterday but the day before i think is when the banks went to zero. It was a glitch and it was over with pretty quickly.
1 person likes this