Just did a speed test and wow it's miserable.

Canada
January 22, 2012 8:29pm CST
At the moment I'm trying to download a 229mb program and it's taking forever. That would be because of my internet speed. To the router it's fine, but to the internet and back it's horrible. Last Result: Download Speed: 57 kbps (7.1 KB/sec transfer rate) Upload Speed: 35 kbps (4.4 KB/sec transfer rate) January-22-12 9:17:36 PM Looks like dialup doesn't it? And we're on high speed with internet speeds that are supposed to be up to 15mbps. Shocking to say the least. But this explains why it's been so bloody slow. But I only have to wait until Tuesday so I think I can put up with it until then. I don't want to, but I have no choice at all.
2 people like this
4 responses
@lovedude (4457)
• India
23 Jan 12
it's very slow speed.. You made me remember of my college days when I was having dialup net and it was downloading with 5-6 Kbps and I was very happy to see remaining time is just 20-30 hours haha.. now I am running with 2-3 MBPS so it's almost 200-300 kbps downloading speed..
1 person likes this
@Hatley (161922)
• Garden Grove, California
23 Jan 12
hi kris that does remind me of when I was downloading some Mozart files and it just took forever as I was on dial up now I have cable internet as all our rooms here at Gold crest are hooked up to cable so just get hooked up and pay time warner and zip for forty dollars]I have jack rabbit fast internet per month.its a stretch for me but worth it but a lot of time mylot itself is snail slow. complain to admins and they goose it up for a month or two. lol hope you can get it rectified soon so its up to speed again Good luck and God bless.
1 person likes this
• Philippines
4 Feb 12
call the ISP and ask them why your internet is so slow they might have some problems in the server
@santuccie (3376)
• United States
24 Jan 12
Where are you conducting this speed test? If this speed is not unique to the site/server from which you're attempting to download this file, then I suspect there is a problem. If you run a speed test at http://speakeasy.net/speedtest/ and get results similar to what you're mentioning here, then try cycling the power to your modem and router by unplugging them, waiting 60 seconds, and plugging back in. If the issue persists, then try connecting a machine directly to the modem. If the issue persists still, then I'd suggest you call your ISP. I have Mediacom's VIP package, and my download speed is also rated at 15 mbps. My tested download speed right now is averaging 5.236 mbps in five consecutive tests, almost 45 times as fast as the speed you're talking about. And usually, my scores are much higher; somewhere between 12 and 20.