I hate internet right now

@carebear29 (28369)
Wausau, Wisconsin
April 14, 2016 8:35pm CST
For some reason all my browsers are acting up. They are slow or taking forever to load (not responding.) The cache and history is cleaned out of them all and they are all still taking forever. I don't know what to do. I have tried Google Chrome, FireFox and Windows Edge (the new IE.) Any suggestions?
10 people like this
10 responses
@sharon6345 (118039)
• United States
15 Apr 16
I cna't even use firefox as it keeps messing up. at least chrome will let me mylot.
3 people like this
• Merced, California
15 Apr 16
Chrome now does not work for me anymore lol
1 person likes this
@maezee (31490)
• United States
15 Apr 16
I just had an issue with my Firefox just totally closing. What's that about! I'm not sure what you would need to do besides clear the cache (that's my answer for everything). Maybe clear up some memory if that could be an issue? Otherwise, maybe it's your internet service is haivng some bandwidt issues or something. Hope it quickens up soon!
3 people like this
@carebear29 (28369)
• Wausau, Wisconsin
15 Apr 16
I hope so too. Its driving me nuts
1 person likes this
@CRK109 (14421)
• United States
15 Apr 16
I'm having problems, too. But I called Verizon and everything checks out with my server. And now I've come to realize that the only time I have real problems is when I'm on this site. I'm not sure why but that's how it is. I haven't tried other browsers yet, but I think I'm going to have to! I hope yours clears up soon!
2 people like this
@carebear29 (28369)
• Wausau, Wisconsin
15 Apr 16
Just yesterday and today we all have had issues. @GoAskAlice is trying to get it dealt with
2 people like this
@CRK109 (14421)
• United States
15 Apr 16
@carebear29 oh that's great!
1 person likes this
• Merced, California
15 Apr 16
Chrome does not work for me on this site i do not know why.
1 person likes this
@just4him (109615)
• Green Bay, Wisconsin
15 Apr 16
Sorry wish I could help. You might want to close all unnecessary browsers.
2 people like this
@carebear29 (28369)
• Wausau, Wisconsin
15 Apr 16
They are all closed
1 person likes this
@akalinus (14613)
• United States
15 Apr 16
@carebear29 Have you restarted? My computer is exceptionally slow today. It goes like that for hours and then suddenly, it is okay again. Restart fixes errors you don't know you have. I actually think there are too many people on the Internet at certain times and there just is not enough to go around.
1 person likes this
@just4him (109615)
• Green Bay, Wisconsin
15 Apr 16
@akalinus I did restart at one point yesterday because it go so slow that nothing was happening at all except error messages.
1 person likes this
@LdeL0318 (6467)
• Philippines
15 Apr 16
I know how it feels. I have been dealing with that for a long time.
2 people like this
@carebear29 (28369)
• Wausau, Wisconsin
15 Apr 16
FireFox was running beautifully then started having issues out of nowhere.
@LdeL0318 (6467)
• Philippines
16 Apr 16
@carebear29 It happens sometimes.
@josie_ (6360)
• Philippines
15 Apr 16
Maybe the problem is with your wi-fi connection?
2 people like this
@carebear29 (28369)
• Wausau, Wisconsin
15 Apr 16
Wifi is fine.
1 person likes this
@ridingbet (46567)
• Philippines
15 Apr 16
i am only on firefox, and when the page is slow to load, i do other things at home
1 person likes this
@carebear29 (28369)
• Wausau, Wisconsin
15 Apr 16
This slowness is driving me up the wall
1 person likes this
@ridingbet (46567)
• Philippines
15 Apr 16
@carebear29 just be patient, my dear, it will get its speed back on track
1 person likes this
@carebear29 (28369)
• Wausau, Wisconsin
15 Apr 16
@ridingbet I know
• Merced, California
15 Apr 16
This is what i was trying to tell you guys when the other day i posted about having problems on mylot, thinking i was banned. Once again my browser is not working just like yours, i have chrome.
1 person likes this
@carebear29 (28369)
• Wausau, Wisconsin
15 Apr 16
Chrome is working a bit better except the shockwave issue crap
@hoong143 (1417)
• Malaysia
15 Apr 16
Maybe you can restart your PC or scan virus.
1 person likes this
@carebear29 (28369)
• Wausau, Wisconsin
15 Apr 16
I did. Oh well, just gotta deal
@jstory07 (65311)
• Roseburg, Oregon
15 Apr 16
I hope you get it all worked out.
1 person likes this
@carebear29 (28369)
• Wausau, Wisconsin
15 Apr 16
Me too